21.1. Prerequisites

repmgr 4 requires PostgreSQL 9.4 or 9.6 with the BDR 2 extension enabled and configured for a two-node BDR network. repmgr 4 packages must be installed on each node before attempting to configure repmgr.

Note: repmgr 4 will refuse to install if it detects more than two BDR nodes.

Application database connections *must* be passed through a proxy server/ connection pooler such as PgBouncer, and it must be possible to dynamically reconfigure that from repmgrd. The example demonstrated in this document will use PgBouncer

The proxy server / connection poolers must not be installed on the database servers.

For this example, it's assumed password-less SSH connections are available from the PostgreSQL servers to the servers where PgBouncer runs, and that the user on those servers has permission to alter the PgBouncer configuration files.

PostgreSQL connections must be possible between each node, and each node must be able to connect to each PgBouncer instance.